Everpad в Ubuntu 15.10

Everpad в Ubuntu 15.10

iSergium

Поддержка сервисов Evernote в Linux - это довольно давняя тема. Официального клиента нет, из сторонних поддержка сервиса советует NeverNote (он же NixNote) и Everpad, который в данной статье и интересен.

На данный момент (середина декабря 2015 года) разработчики Everpad ещё не опубликовали в launchpad версию для вышедшей в октябре Ubuntu 15.10 Wily Werewolf (и, соответственно, для всех основанных на ней дистрибутивов), остановившись на 15.04 Vivid Vervet. Эта версия полностью совместима с новой ОС, но существует немного трудностей при установке, о них и будет вестись повествование.

Итак, есть Ubuntu 15.10 и на неё нужно поставить Everpad. Согласно заявлению разработчиков установка Everpad происходит так:

sudo add-apt-repository ppa:nvbn-rm/ppa
sudo apt-get update
sudo apt-get install everpad

1. PPA

В приведённом выше добавлении репозитория один минус - он добавится с привязкой к версии 15.10 Wily, которая пока ещё не поддерживается и потому пакет Everpad в нём не найдётся. Из-за этого добавлять репозиторий нужно с привязкой к 15.04 Vivid:

sudo add-apt-repository "deb http://ppa.launchpad.net/nvbn-rm/ppa/ubuntu vivid main"

Если Вы уже добавили репозиторий методом от разработчиков, то его можно подправить в "Параметры системы" → "Программы и обновления" → "Другое ПО", сменив дистрибутив у "http://ppa.launchpad.net/nvbn-rm/ppa/ubuntu" с "wily" на "vivid".

Данный метод можно применять к любому другому пакету с launchpad и некоторых его аналогов.

2. Связи

Попытка установить Everpad приводит к не самому радостному вердикту:

Некоторые пакеты невозможно установить. Возможно, вы просите невозможного,
или же используете нестабильную версию дистрибутива, где запрошенные вами
пакеты ещё не созданы или были удалены из Incoming.
Следующая информация, возможно, поможет вам:

Пакеты, имеющие неудовлетворённые зависимости:
 everpad : Зависит: python-oauth2 но он не может быть установлен
           Зависит: python-unity-singlet но он не может быть установлен

Попытки установить эти пакеты через apt-get тоже не радуют. Потому их легче всего установить вручную: python-oauth2, unity-singlet. Какие-либо дополнительные пакеты можно найти по этой ссылке. Так как речь идёт про Ubuntu, то выбрать лучше deb-файлы - с ними меньше возни. Скачать, установить, затем консоль:

sudo apt-get install everpad

Теперь программа Everpad установлена, можно пользоваться.